Security Notice – Heartbleed Bug

April 23, 2014 in Latest News

As many of our members are aware a security vulnerability known as the Heartbleed Bug was found within OpenSSL, the open-source encryption standard used by the majority of websites that need to transmit data securely such as usernames and passwords.

We have confirmed that none of our systems have been compromised by this security vulnerability. It is however our policy to recommend that members change their passwords regularly to minimise password exploits.

If you have any further concerns, you can find further information about the Heart Bleed Bug on their website heartbleed.com or contact us via info@mcu.com.au.